Back to overview
Downtime

Power Outage

Aug 25 at 05:15am CEST
Affected services
titan.mairel.com
webmail.mairel.com
cPanel Services

Resolved
Aug 25 at 10:00am CEST

Around 10.00 AM local time, all the power has been restored and all services are up and running again. We will keep monitoring the situation and will discuss what this means in the future with the datacenter.

The needed precautions to prevent this in the near future are being taken in the form of more diesel aggregates for backup power. For now the power is back up and will be closely monitored.

Created
Aug 25 at 05:15am CEST

Since around 5 AM local time this morning our datacenter lost their main power. The root cause is still being investigated but it might have to do with the temperatures we are facing during these months.